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1. Introduction 
 

The “BMSKTOPASM369BT(kc) version 2” starter kit makes it possible to easily evaluate TOSHIBA 
Bluetooth® LSI “CHIRON”, TC35661 and the Microcontroller TMPM369FDFG that offer the connectivity 
as  Ethernet, CAN, USB host, USB device, UART, SIO, SPI and I2C.   

 

The board uses the Panasonic (PIDEU) Bluetooth® module PAN1026 that has embedded the TC35661.  

http://pideu.panasonic.de/products/wireless-modules/bluetooth/bluetooth-40-dual-mode/pan1026-
bluetooth-classic-and-low-energy-embedded-dual-mode-module.html 

 

 

Starter-Kit Content: 

• Toshiba TOPAS369BT Board 

• Segger J-Link JTAG/SWD Emulator with USB interface including J-Link 19-pin Cortex-M Adapter 
and USB Cable 
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1. Step ONE: Driver Installation for Segger J-Link JTAG/SWD 
Emulator 

 

!  Before you connect the debug probe to the target board, please install the drivers first. 

 

 

 

1. Before you plug your J-Link / J-Trace into your computer’s USB port, extract the 
setup tool Setup_JLinkARM_V<VersionNumber>.zip. The setup wizard will install the 
software and documentation pack that also includes the certified JLink USB driver. 
 

 
 

2. Start the setup by double clicking Setup_JLinkARM_V<Version-Number>.exe. 
More information about the installation and about the debug probe itself can be found 
on the Segger website. 

 

3. Connect your J-Link via USB with your PC. The J-Link will be identified and after a 
short period the J-Link LED stops rapidly flashing and stays on permanently. 
 

Link: http://www.segger.com/cms/jlink.html 
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2. Step TWO:  
 

Depending on your preferences you may want to install and use one of the following IDEs with our 
board: 

• Keil MDK TM  with µVision® IDE/Debugger 

• IAR® Kickstart Edition 

• Atollic®  TrueStudio® Lite 

 

Keil MDKTM 
 

Software Tool Vendor : KeilTM, www.keil.com  

Name of Environment : MDK-ARMTM , including Keil TM µVision®4 IDE/Debugger  

Software Download Site : https://www.keil.com/demo/eval/arm.htm  

 

The Keil MDKTM μVision® software works together with the Segger J-Link and other tools. You can 
download the latest version from the software download site. 

1. When you click on download you will have to 
register on the following form: 

 

2. After registration you will be send to the 
download page, from where you can get the 
latest version of the software. Please download 
the file to your computer. 

 

 

3. Start the executable file.  
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4. At the end of the installation you will be asked 
for selecting the example projects. 
Select Toshiba Boards. 

 

5. If you have a registration code for ARM-MDKTM 
and want to install this, start up Keil MDKTM. 
Select File → Licence Manager. 

6. Click on “Get LIC via Internet”  
7. On the opened Browser page fill in the code you 

have received under “Product Serial # (PSN)” 
8. After submitting you will receive a mail with the 

LIC. 
9. Copy this over to the “New Licence ID Code 

(LIC)” field and click “Add LIC”. 
 

 

 

IAR EWARM® 
 

Software Tool Vendor : IAR ® , www.iar.com  

Name of Environment : Evaluation edition of IAR ® Embedded Workbench for ARM  

Software Download Site : 
http://www.iar.com/Products/IAR-Embedded-
Workbench/ARM/ 

 

 

You can download the latest version from IAR® website under the link mentioned above. You have to 
register to download the Kickstart edition in example. 
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1. When you click on “continue” you will be send 
to the registration form. 

 

2. On the registration form you have to enter 
some basic information and answer some 
questions about your project. 

3. After registration you will receive an email with 
further instruction. 

 

4. By confirming this registration you will open the 
download webpage which also contains your 
license number and license key. 
Optionally you can allow receive this 
information by email for later use. You should 
do this ! 

5. Download the executable from one of the listed 
websites. 
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6. Start the downloaded executable file. 
7. Click on “Install IAR Embedded Workbench” 

 

8. Click on “Next” until you have to enter the User 
Information. 

9. Please enter your Name and Company. 
10. Enter or copy the License number from the 

Email you have received before. 
11. Click “Next”. 

 

12. In the screen “Enter License Key”, please copy 
the license key from the registration email. 

13. Click “Next” 
14. The installation will start now. Depending on 

the speed of your system this may take quite a 
while. 
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Atollic® Truestudio®  
 

Software Tool Vendor : Atollic® , www.atollic.com  

Name of Environment : Atollic®  TrueSTUDIO® Lite  

Software Download Site : http://www.atollic.com/index.php/download   

 

The Atollic® software works together with the Segger J-Link and other tools. You can download the 
latest version from the software download site. 

 

1. Start the installer. 
You will see the following screen popping up 
with your computer ID. You will require this 
information for the registration process. You 
will receive a license key that you have to enter 
into the second text area of this screen. 

 

2. Go to the Atollic® website at 
http://www.atollic.com/index.php/registerlite 
to continue your registration process. 

3. Fill out all registration data and click on register. 
4. You will receive a mail with the installation key. 
5. Copy this key and place it in the installation key 

box at the bottom of the installer window. 
6. Just press the install button and wait until 

installation has finished. 
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3. Step THREE: Hardware Setup of the M369BT STK MCU Board 
 

Place the MCU Board in front of you as below. The major connectors on the board are as follows. 

 

 

The board can be powered in three ways: 

o By the USB client connector 

o By the debug connector 

o By the DC jack connector 

These three inputs are wired OR by diodes. There is no need to select a power input by a jumper. 

!!! Please note when you make use of the power supply by a debug probe like the JLINK that comes with 
that starter kit, that this function is disabled by default. This can be enabled by the J-Link Commander 
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(JLink.exe) is a command line based utility that is part of the Segger J-Link software package. When you 
enter at the prompt the command “power on perm” power supply to the target will be done by the J-LINK. 

http://www.segger.com/j-link-commander.html 

 

The main voltage of 3.3 volt is derived by a linear regulator. Hence DC jack input voltage must be in a 
range from 5...12 volts. 

The USB host supply voltage of 5 volts is generated by a step-up converter from the 3.3 V bus. Please 
note that the current capability of this USB host is much lower than the USB specification of 500mA 
(~100mA). 

The +5V power of the USB host connector is switchable via port PK3 (active high enable) and has 
overcurrent detection connected to PK1 (active low trigger). 

 

There are a few buttons and LEDs 

 

• The joystick is connected to the port PD0...PD4. 

• The user LEDs are connected to the port PC0...PC3. 
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There are some jumpers for power measurement and a jumper to enter the device operation mode 
named boot mode.  

 

Jumpers JPx: 

The jumpers JP1 and JP2 are normally closed. They can be opened to separate the microcontroller or the 
Bluetooth module from VCC and to insert an ammeter there in order to measure current draw. 

• JP1 is for TMPM369. 

• JP2 is for PAN1026. 

• JP3 can be used to connect the BOOT-mode-pin of the microcontroller to GND. 

Resistors Jx: 

These 0-Ohm resistors can be easily identified because their SMD size is 0805 (regular resistors are SMD 
size 0603). 

They are populated by default, except J3, and can be de-soldered to change the behavior of the board. 

• J2 connects of PHY interrupt to MCU port PI3 
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• J3 connects LED of the PHY to MCU port PH7 

• J4 connects reset input of the PHY to the reset button. 

• J5 connects power input of the usb client connector to MCU port PK0 

• J6 connects STB line of ZJA1040 CAN-Transceiver to GND. 

• J7 connects pin 5 of CAN-connector to GND. 

 

4. Step FOUR: Start the Sample Project 
 

There are several software examples provided for the Microcontroller TMPM369. Hereby we show in a 
few steps how to start, compile and debug with an example that use the LED.  

Please note that the project files are for the IAR ®  Tool chain. However, the sources could be used any 
tool environment. 

The software CMSIS driver, example and manual download: 

http://www.toshiba-components.com/microcontroller/Application_conf.html 
 

1. Open a workspace from the folder by 
click on “TRMB_TIMER.eww” or by the 
menu within the IDE.  
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2. Follow the instructions in the Example 
description to configure the board, 
and choose your build configuration, 
for example “Debug iRAM”. 

3. Choose Project>Make or click the 
button on the toolbar. The project 
should compile with no errors or 
warnings. 

4. To download your program, choose 
Project>Download and Debug or click 
the button. The file main.c is now 
open in the editor window. Choose 
Debug>Go or click the button to start 
the application. 

5. To stop C-SPY, choose Debug>Break or 
click the button. 

6. To exit C-SPY, choose Debug>Stop 
Debugging or click the button. 
 

 

5. Step FIVE: Start with Bluetooth 
 

The Toshiba Bluetooth® LSI TC35661SBG has been embedded - including its SPP profile - into the 
Panasonic (PIDEU) module PAN1026. The embedded stack and profile were Bluetooth™ SIG approved 
through extensive BQB (Bluetooth™ Qualification Body) tests.  The module is ideal for cable 
replacements.  System developers can make use of the Serial Port Profile functionality through the 
comfortable Toshiba API interface over UART. 

The Embedded SPP (Serial Port Profile) Application Note download:  

http://www.toshiba-components.com/bluetooth/index.html 
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6. Pin Out of Connectors 
 

CAN Connector 

    
 

1 2 GND 
CAN_L 3 4 CAN_H 
GND 5 6  

 
7 8 V+ ( 5V ) 

 
9 10  

 

Connector: CAN Signals according to CiA 
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Pin Header Connector 

 

TMPM369 has several ports. These ports are also used as input/output pins as well as for built-in 
peripheral functions. For the header pin some terminal has been selected. The description below shows 
the major function, for all please see TMPM369 Data Sheet.  

                                                                                

PJ0 / AINB4  1 2 PJ1 / AINB5 
PJ2 / AINB6 3 4 PJ3 / AINB7 

PAN - GPIO05/FSYNC 5 6 GPIO16/DIN - PAN 
PAN - GPIO17/CS0X 7 8 GPIO18/CS1X - PAN 

DA0 9 10 DA1 
PI0 / AIN0 / INT9 11 12 PI1 / AIN1 / INTA 
PI2 / AIN2 / INTB 13 14 VCC 

PE4 / SCLK1 /  CTS1 / TB2OUT 15 16 PE5 / TXD1 
PE6/ RXD1 17 18 PE7 / INT6 / TB2IN 

GND 19 20 PF6 / DSR4 / SI1 /SCL1 
PF7 / DTR4 / SO1/SDA1 21 22 PG0 / MT0IN 

PG1 23 24 PG2 / MTOUT10 /MTTB0IN 
PG3 / MTOUT00 / MTTB0OUT 25 26 PG4 / SP1CLK 

PG5 / SP1DO 27 28 PG6 
PG7 / SP1FSS 29 30 PB2 /SP2CLK / MTOUT03 /MTTB3OUT 

PB3 / SP2DO /MTOUT13 /MTTB3IN 31 32 PB4 / SP2DI / INT7 
PB5 / SP2FSS / MT3IN / INT1 33 34 PH1 / TB4OUT / SI2 / SCL2 

PH0 / TB5OUT / MT2IN / SO2/SDA2 35 36 /NMI 
 

Connector: Pin Header 

Note: BMSKTOPASM369BT(kc) version 1 has different pin header. 
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7. Important Notice 
 

 Intended Usage 

o The board should be used for evaluation. It should be used in proper environment.  It is 
not intended and not recommended to be used in any final product.   

 Conformity 

o The board passed the requirements of the radiated emission according to EN 61326-1 
(CISPR 11) class A.   

o When using the boards in a Class B environment (residential and small commercial area) 
there is possibility to have increased radiation due to the LAN LSI oscillator frequency.  

 Known Limitations 

o EEPROM: Please note that the schematics has been made using an EEPROM that use A2 
terminal as “User Configurable Chip Select” and therefore it has been connected to 
logical 0 (GND). The 24LC1025 on the board use that terminal as block and not as chip 
select and it has to be connected to logical 1 (VCC).  As a result only lower block, 512K 
bit, can be used for evaluation.  

8. Revisions 
 

Revision Date Description 

0.91 31.05.2013 Initial Version for Board V1 

01 30.07.2014 Initial Version for Board V2 

02 27.01.2014 Add chapter “1. Important 
Notice” and “Revisions”. Update 
pictures and some contents 
revised. 
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9. Disclaimer 
 

RESTRICTIONS ON PRODUCT USE 

 Toshiba Corporation, and its subsidiaries and affiliates (collectively “TOSHIBA”), reserve the right to make 
changes to the information in this document, and related hardware, software and systems (collectively 
“Product”) without notice. 

 This document and any information herein may not be reproduced without prior written permission from 
TOSHIBA. Even with TOSHIBA’s written permission, reproduction is permissible only if reproduction is without 
alteration/omission. 

 Though TOSHIBA works continually to improve Product's quality and reliability, Product can malfunction or fail. 
Customers are responsible for complying with safety standards and for providing adequate designs and 
safeguards for their hardware, software and systems which minimize risk and avoid situations in which a 
malfunction or failure of Product could cause loss of human life, bodily injury or damage to property, including 
data loss or corruption. Before customers use the Product, create designs including the Product, or 
incorporate the Product into their own applications, customers must also refer to and comply with (a) the latest 
versions of all relevant TOSHIBA information, including without limitation, this document, the specifications, 
the data sheets and application notes for Product and the precautions and conditions set forth in the 
"TOSHIBA Semiconductor Reliability Handbook" and (b) the instructions for the application with which the 
Product will be used with or for. Customers are solely responsible for all aspects of their own product design or 
applications, including but not limited to (a) determining the appropriateness of the use of this Product in such 
design or applications; (b) evaluating and determining the applicability of any information contained in this 
document, or in charts, diagrams, programs, algorithms, sample application circuits, or any other referenced 
documents; and (c) validating all operating parameters for such designs and applications. TOSHIBA 
ASSUMES NO LIABILITY FOR CUSTOMERS' PRODUCT DESIGN OR APPLICATIONS. 

 Product is intended for use in general electronics applications (e.g., computers, personal equipment, office 
equipment, measuring equipment, industrial robots and home electronics appliances) or for specific 
applications as expressly stated in this document. Product is neither intended nor warranted for use in 
equipment or systems that require extraordinarily high levels of quality and/or reliability and/or a malfunction or 
failure of which may cause loss of human life, bodily injury, serious property damage or serious public impact 
(“Unintended Use”). Unintended Use includes, without limitation, equipment used in nuclear facilities, 
equipment used in the aerospace industry, medical equipment, equipment used for automobiles, trains, ships 
and other transportation, traffic signaling equipment, equipment used to control combustions or explosions, 
safety devices, elevators and escalators, devices related to electric power, and equipment used in finance-
related fields. Do not use Product for Unintended Use unless specifically permitted in this document. 

 Do not disassemble, analyze reverse-engineer, alter, modify, translate or copy Product, whether in whole or in 
part. 

 Product shall not be used for or incorporated into any products or systems whose manufacture, use, or sale is 
prohibited under any applicable laws or regulations. 

 The information contained herein is presented only as guidance for Product use. No responsibility is assumed 
by TOSHIBA for any infringement of patents or any other intellectual property rights of third parties that may 
result from the use of Product. No license to any intellectual property right is granted by this document, 
whether express or implied, by estoppel or otherwise. 

 ABSENT A WRITTEN SIGNED AGREEMENT, EXCEPT AS PROVIDED IN THE RELEVANT TERMS AND 
CONDITIONS OF SALE FOR PRODUCT, AND TO THE MAXIMUM EXTENT ALLOWABLE BY LAW, 
TOSHIBA (1) ASSUMES NO LIABILITY WHATSOEVER, INCLUDING WITHOUT LIMITATION, INDIRECT, 
CONSEQUENTIAL, SPECIAL, OR INCIDENTAL DAMAGES OR LOSS, INCLUDING WITHOUT 
LIMITATION, LOSS OF PROFITS, LOSS OF OPPORTUNITIES, BUSINESS INTERRUPTION AND LOSS 
OF DATA, AND (2) DISCLAIMS ANY AND ALL EXPRESS OR IMPLIED WARRANTIES AND CONDITIONS 
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RELATED TO SALE, USE OF PRODUCT, OR INFORMATION, INCLUDING WARRANTIES OR 
CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, ACCURACY OF 
INFORMATION, OR NONINFRINGEMENT. 

 Do not use or otherwise make available Product or related software or technology for any military purposes, 
including without limitation, for the design, development, use, stockpiling or manufacturing of nuclear, 
chemical, or biological weapons or missile technology products (mass destruction weapons). Product and 
related software and technology may be controlled under the Japanese Foreign Exchange and Foreign Trade 
Law and the U.S. Export Administration Regulations. Export and re-export of Product or related software or 
technology are strictly prohibited except in compliance with all applicable export laws and regulations. 

 Product may include products subject to foreign exchange and foreign trade control laws. 

 The technical information described in this document is subject to foreign exchange and foreign trade control 
laws. 

 Please contact your TOSHIBA sales representative for details as to environmental matters such as the RoHS 
compatibility of Product. Please use Product in compliance with all applicable laws and regulations that 
regulate the inclusion or use of controlled substances, including without limitation, the EU RoHS Directive. 
TOSHIBA assumes no liability for damages or losses occurring as a result of noncompliance with applicable 
laws and regulations. 

 

 

 

 

 

 

 

 

 
 


